Le applicazioni GTK+ in KDE

Finiti gli esami, è tempo di tornare al blog, almeno brevemente! Ecco, ci sono già mille articoli sparsi per la rete, pur tuttavia nonostante benchè però inquantochè, ho avuto bisogno di molto tempo e qualche piccolo sforzo extra per integrare Firefox ed Emesene (che peraltro non uso) in Kde. Il primo suggerimento che avevo trovato è chiamato QtCurve, ovvero "set di stili widget" (per quel che posso interpretare: un tema) comuni ad applicazioni GTK e QT indiscriminatamente. Se non fosse che non mi piace per niente – non voglio un tema simile o comune, voglio che le applicazioni si adattino al tema che scelgo di volta in volta! Questo si dovrebbe poter ottenere con Gtk-Qt-Engine, il fratello di QGtkStyle. Per molto tempo non mi sono nemmeno accorto di avere entrambi i "sistemi" installati (QtCurve e l’engine GTK). Quando l’ho scoperto ho pensato di rimuovere QtCurve. Per poi scoprire che, invece, Firefox assumeva di nuovo l’orrenda apparenza di default ("tema non impostato", potremmo chiamarlo). Ci ho pensato un po’ su, ho riprovato le varie configurazioni nelle Impostazioni di Sistema di KDE, senza risultato. Tristemente, ho reinstallato QtCurve per riottenere il risultato amico. Ma non mi sono arreso: se un pacchetto è inutile, DEVE essere rimosso, per quanto poco fastidio possa dare! Oggi ho svelato l’arcano: esistevano nella mia $HOME tre file particolari. Uno è il famoso .gtkrc. Gli altri, sono file con struttura e nome molto simile (tra loro, ma anche a .gtkrc!): .gtkrc-2.0-kde e .gtkrc-2.0-kde4. Andando a sondare il contenuto, ho trovato che il primo di questi due richiama l’engine GTK (Gtk-Qt-Engine), mentre il secondo si riferiva al tema QtCurve. Ho allora capito: per qualche ragione, le applicazioni GTK leggevano questo secondo file e, non trovando il tema QtCurve, assumevano l’aspetto orrendo. Il problema è però piuttosto strano: significa che le Impostazioni di Sistema scrivono su un file che non è letto dalle applicazioni GTK (dato che anche riprovando e riprovando, il file scritto è sempre *kde e non *kde4)! Io ho risolto facendo di .gtkrc*kde4 un link simbolico a .gtkrc*kde. Resta da capire dov’è il bug. Ma per fortuna, almeno il problema è temporaneamente risolto!

Coming Soon: Il racconto folle di un impossibile passaggio – diretto! – da Ubuntu a Debian. Ovvero, come perdere qualche giornata utile di studio.
Annunci